Installing Citrix Client on Ubuntu 9.10

Install OpenMotif

sudo aptitude install libmotif3

Unfortunately, Ubuntu only provide the obsolete libmotif3 version and the not the current version 4 that the receiver is built against.
The easiest solution is to install libmotif3 and then run

sudo ln -s /usr/lib/libXm.so.3.0.2 /usr/lib/libXm.so.4

Download the latest Citrix Client from:
http://citrix.com/English/ss/downloads/
Search Downloads by Product > Citrix Xenapp > Linux Client
Select:
Version 11.0 English German Japanese 3/2/09 2.1 mb .deb
x86 client – requires OpenMotif v.2.3.1
Install the .deb with GDebi.

Done

Posted in Linux and tagged , .

Leave a Reply